bu excel katiline bir yardım :D

Katılım
1 Ksm 2010
Mesajlar
2
Beğeniler
0
Yaş
32
#1
arkdaşlar merhaba;

benim excel bilgim sadece yaptığım küçük formullemeler yanlız nezamandır üstünde çalıştığım :v ve yapamadığım bir işlemim var bana yardımcı olmanızı diliyorum konum şu;

[sayfa 1] [sayfa 2]
a sütünu b sütünu a sütünu b sütünu
1 11-89-51 12358966 1 11-89-51 ?
2 12-54-89 65247896 2 12-54-89
3 12-54-81 11315613 3 12-54-81
4 12-54-85 25464646 4 12-54-85
5 12-54-82 41646464 5 12-54-82
6 12-54-83 46464966 6 12-54-83
7 12-54-84 14156416 7 12-54-84
8 12-54-86 54654666 8 12-54-86
9 12-54-62 65464694 9 12-54-62
1012-54-21 64464464 10 12-54-21

yukarıda ki tabloda çalışmamın ufak bir krokisidir.Sayfa1 deki a sütünunda yaklaşık olarak 5000 adet birbirinden farklı kod ve b sütünunda bulunlara karşılık gelen (eşdeğeri olan) 5000 adet birbirinde farklı numaralar mevcuttur.
benim yapmak istediğim sayfa2de a sutununa yazdığım 12-54-62 kodunun sayfa1 deki karşılığı olan numaraların b sutununa kendiliğinden yapışmasıdır.
acaba böyle bir şey yapılabilirmi?
ilginiz için teşekkürler...
 

YoRuMSuZ

Biz işimize bakalım...
Katılım
7 Hzr 2006
Mesajlar
37,851
Beğeniler
9,497
Şehir
Antalya
Takım
GALATASARAY
#2
Yapılabilir hocam. Ama bir ekran görüntüsü veya excel dosyanızı herhangi bir upload sitesine yüklerseniz daha kolay anlayabilirim.

Ayrıca konuyu Excel Çalışmaları / İpuçları bölümüne taşıyorum.

Sayfa1 deki herhangi bir hücre içeriğini Sayfa2 de göstermek için Sayfa adı ile birlikte ünlem kullanmak yeterli.

Örneğin Sayfa1 deki A1 hücresinin içeriğini Sayfa2'de herhangi bir hücrede göstermek için Sayfa2'ye gidin ve herhangi bir hücreye =Sayfa1!A1 formülünü yazın.
 
Katılım
1 Ksm 2010
Mesajlar
2
Beğeniler
0
Yaş
32
#3
önceliklee teşekkür ederim ilgilendiğin için ama sanırım ben anlatamadım.acaba çalışacağım excel dosyasını sana nasıll ulaştırailirim
 

YoRuMSuZ

Biz işimize bakalım...
Katılım
7 Hzr 2006
Mesajlar
37,851
Beğeniler
9,497
Şehir
Antalya
Takım
GALATASARAY
#5
Verilen tablo anlaşılır olsaydı daha erken çözerdik ancak çok karışık verilmiş.

Çözüm için;

Sayfa 2'ye gelip B1 hücresine alttaki formülü girin.
Kod:
=EĞER(A1=Sayfa1!A1;Sayfa1!B1;"boş")
Daha sonra formülü yazdığınız B2 hücresinin sağ alt köşesinden maus + şeklini aldıktan sonra tutun ve alta doğru gerektiği kadar sürükleyin.

Artık Sayfa 2'de A sütununa yazdığınız kodların karşılığı varsa hemen yanına otomatik yazacaktır. Ancak aynı satırların birbiri ile örtüşmesi gerekir.
 

YoRuMSuZ

Biz işimize bakalım...
Katılım
7 Hzr 2006
Mesajlar
37,851
Beğeniler
9,497
Şehir
Antalya
Takım
GALATASARAY
#6
Düşündüm de sizin işinizi DÜŞEYARA fonksiyonu çok daha iyi görecektir :) Böylece aynı satırın aynı satıra gelme zorunluluğunu ortadan kaldırabiliriz.

Bu örnekte verilerin Sayfa 1'de A1-A10 ve B1-B10 arasında olduğunu varsayıyorum. Tabi siz kendinize göre formülü düzenlemelisiniz.

Sayfa 2'ye geçelim ve B1 hücresine alttaki formülü girelim.
Kod:
=DÜŞEYARA($A$1:$A$10;Sayfa1!$A$1:$B$10;2;YANLIŞ)
Daha sonra B1 hücresinin sağ alt köşesinden tutup formülü B sütununda istediğiniz yere kadar sürükleyin. (Her hücrede aynı formül olmalı)

Böylece Sayfa 2'de A sütununa yazdığınız her kodun karşılığı B sütununda karşılık olarak gelecektir.
 
Top Bottom