1. * 5651 Sayılı Kanun'a göre TÜM ÜYELERİMİZ yaptıkları paylaşımlardan sorumludur.
    * Telif hakkına konu olan eserlerin yasal olmayan şekilde paylaşıldığını ve yasal haklarının çiğnendiğini düşünen hak sahiplerinin İLETİŞİM bölümünden bize ulaşmaları durumunda ilgili şikayet incelenip gereği 1 (bir) hafta içinde gereği yapılacaktır.
    E-posta adresimiz

Excel de ayrı sütunlardaki satırları çarparak toplamak-YARDIM

Konusu 'Excel Çalışmaları' forumundadır ve moskovalı tarafından 13 Ekim 2008 başlatılmıştır.

  1. moskovalı

    moskovalı Üyecik

    Katılım:
    13 Ekim 2008
    Mesajlar:
    6
    Beğenileri:
    0
    Ödül Puanları:
    20
    Banka:
    0 ÇTL
    Merhaba,
    Excel de
    A B
    A1 2 1
    A2 3 2
    A3 6 4
    A4 5 1
    .................
    şeklinde iki sütun var. (A1*B1)+(A2*B2)+(A3*B3)+(A4*B4).....
    C de herhangibir satıra bu toplamı yazdırmak istiyorum.
    Üstteki işlemini daha kolay yapacak bir formül var mı?
    Şimdiden teşekkürler...
     
  2. YoRuMSuZ
    Avare

    YoRuMSuZ Biz işimize bakalım!

    Katılım:
    7 Haziran 2006
    Mesajlar:
    24.429
    Beğenileri:
    7.355
    Ödül Puanları:
    11.330
    Cinsiyet:
    Bay
    Banka:
    8.817 ÇTL
    Bu belki daha kısa bir formülle yapılabilir ancak yapılıyorsa da ben bilmiyorum. Uzun listelerde formülün çok fazla uzayıp gitiğini düşünüyorsanız biraz daha kullanışlı hale getirebilir. Örneğin benim uzun bir listede böyle bir duruma ihtiyacım olsa yönetimim şu olurdu.

    Bunun için F sütunun kullanalım. F1 hücresine =A1*B1 formulünü girip sağ alt köşesinden fare ile tutup listem boyunca sürüklerim. Örn; 25. satıra kadar yaptık. Artık 25. satıra kadar A1 ve B1 hücrelerine hangi rakam girilirse girilsin karşılarında toplamları olacak.

    Sonra C sütununda herhangi bir hücreye =TOPLA(F1:F25) formülünü girelim ve F sütununu kullanıcıdan gizleyelim. Böylelikle formülümüz çok daha stabil çalışacak. Hem de satırlardaki sayıları çarptığımız sütun görünmeyecek.

    Artı her seferinde satır ekledikçe formülümüze yeni eklemeler yapmak zorunda kalmayacağız.

    Alternatif fikirleri olanlar da olabilir. Bu benim önerim.
     
  3. moskovalı

    moskovalı Üyecik

    Katılım:
    13 Ekim 2008
    Mesajlar:
    6
    Beğenileri:
    0
    Ödül Puanları:
    20
    Banka:
    0 ÇTL
    Mutlaka tek hücrede bu işlemin yapılabileceği bir formül olmalı diye düşünüyorum.
    Lütfen yardım edin arkadaşlar.
     
  4. carpediem24

    carpediem24 Katılımcı

    Katılım:
    26 Şubat 2008
    Mesajlar:
    179
    Beğenileri:
    1
    Ödül Puanları:
    630
    Yer:
    ADIYAMAN
    Banka:
    0 ÇTL
    paylaşım için tskler
     
  5. moskovalı

    moskovalı Üyecik

    Katılım:
    13 Ekim 2008
    Mesajlar:
    6
    Beğenileri:
    0
    Ödül Puanları:
    20
    Banka:
    0 ÇTL
    Paylaşılmayan bilgi bilgi değildir arkadaşlar. Lütfen paylaşalım.
     
  6. mtan1972

    mtan1972 Üyecik

    Katılım:
    19 Ekim 2008
    Mesajlar:
    1
    Beğenileri:
    0
    Ödül Puanları:
    20
    Banka:
    0 ÇTL
    istediğin hücreye =(A1*B1)+(A2*B2)+(A3*B3)+(A4*B4) yazarak işlemi yaparsın daha kolayı olsa ne olacak ki işlemi exel yapacak nasıl olsa.
     
  7. moskovalı

    moskovalı Üyecik

    Katılım:
    13 Ekim 2008
    Mesajlar:
    6
    Beğenileri:
    0
    Ödül Puanları:
    20
    Banka:
    0 ÇTL


    Satır sayısı 5.000 ise bu işlemi yapmak epey zaman alacaktır, sence?
     
  8. YoRuMSuZ
    Avare

    YoRuMSuZ Biz işimize bakalım!

    Katılım:
    7 Haziran 2006
    Mesajlar:
    24.429
    Beğenileri:
    7.355
    Ödül Puanları:
    11.330
    Cinsiyet:
    Bay
    Banka:
    8.817 ÇTL
    Neden tek hücrede bunu yapmak istediğinizi anlayamadım. Zaten yukarıda belirttiğiniz şekilde bunu yapabilmeniz mümkün değil eğer 5.000 satırlı bir tablo varsa. Bakın inceleyin bütün muhasebe, cari stok programlarında hücre hesaplamaları için gizlenmiş sütunlar kullanılır. Böylece excel çok daha stabil çalışacaktır verileri çekerken.

    Artı bir avantajı da her satır eklediğinizde formülde herhangi bir değişiklik yapma gereği duymazsınız. İlk mesaja verdiğim cevap hala geçerli benim açımdan.

    Ancak maro yardımıyla sizin isteğinizin gerçekleşeceğini düşpünüyorum. Makrolar konusunda bilginiz varsa yazabilir belgenizde kullanabilirsiniz.
     
  9. biz

    biz Aktif

    Katılım:
    12 Şubat 2007
    Mesajlar:
    324
    Beğenileri:
    3
    Ödül Puanları:
    630
    Banka:
    0 ÇTL
    Bende araştırdım yorumsuz un dediği gibi ya makro yada gizli formül satırı başka yolu yok
     
  10. moskovalı

    moskovalı Üyecik

    Katılım:
    13 Ekim 2008
    Mesajlar:
    6
    Beğenileri:
    0
    Ödül Puanları:
    20
    Banka:
    0 ÇTL

    Ben buldum yolunu;

    =СУММ(A1:A5000*B1:B5000)
    formül yazıp ctrl+shift+enter basiyoruz ve toplami aliyoruz
     

Sayfayı Paylaş