1. * 5651 Sayılı Kanun'a göre TÜM ÜYELERİMİZ yaptıkları paylaşımlardan sorumludur.
    * Telif hakkına konu olan eserlerin yasal olmayan şekilde paylaşıldığını ve yasal haklarının çiğnendiğini düşünen hak sahiplerinin İLETİŞİM bölümünden bize ulaşmaları durumunda ilgili şikayet incelenip gereği 1 (bir) hafta içinde gereği yapılacaktır.
    E-posta adresimiz

Excel ile Sınav Analizi yapalım

Konusu 'Excel Çalışmaları' forumundadır ve YoRuMSuZ tarafından 27 Mart 2012 başlatılmıştır.

  1. YoRuMSuZ
    Avare

    YoRuMSuZ Biz işimize bakalım!

    Katılım:
    7 Haziran 2006
    Mesajlar:
    24.416
    Beğenileri:
    7.327
    Ödül Puanları:
    11.330
    Cinsiyet:
    Bay
    Banka:
    8.722 ÇTL
    Excel içerisinde işlerimizi kolaylaştıran bir çok işlev ve fonksiyonu barındırıyor. Biz şimdi basit düzeyde sınav analiz programı yapalım. Böylece bazı formüllerin nasıl kullanıldığını da öğrenmiş olalım.

    İsterseniz uygulama dosyasını eklentiden indirebilirsiniz.

    Konu: Excel ile sınav analizi
    Zorluk: Basit / Orta

    Bunun için aşağıdaki resimde görüldüğü gibi 3 sayfadan oluşan bir excel dosyası kullanıyoruz. Aynı isimleri kullanırsanız formülleri kullanmada zorluk çekmezsiniz.

    Sayfa isimleri: Liste-Cevap, Cevaplar, Sonuclar

    Liste-Cevap sayfası bizim veri gireceğimiz sayfadır. Diğer sayfalara elle veri girmiyoruz, çünkü diğer sayfalar sonuçları bu sayfadan formüllerle alacak. Resimdeki şekilde tablomuzu hazırladık ve doğru üstteki bölüme doğru cevapları, öğrencilerin bölümüne ise öğrencilerin sınavda verdikleri cevapları giriyoruz.

    Buradaki sınav sonuçları bir hücreye girilip (kolaylık olması açısından) daha sonra PARÇAAL fonksiyonu ile ayıracağız.

    Öğrencinin boş bıraktığı soru için biz de bir boşluk bırakıyoruz. 1 numaralı öğrencinin cevaplarında görüldüğü gibi.

    [​IMG]

    Artık sonuçları almaya başlıyoruz. Aşağıdaki resimde görüldüğü gibi bir tablo hazırlayalım ve verileri Liste-Cevap sayfasından çekmeye başlayalım. Girdiğimiz formülleri diğer hücrelere uygulamak için sürükleyip bırakmak yeterli.

    Burada önemli olan Doğru cevapları ve öğrencilerin verdikleri cevapları PARÇAAL fonksiyonu ile almak ve

    E1 hücresine doğru cevapları parçalayarak almak için şu formülü yazalım ve soru sayısına göre sağa doğru sürükleyelim.
    Kod:
      Kodları görebilmek için ÜYE omalısınız !
    E3 hücresine de öğrencilerin verdiği cevapları almak için alttaki formülü yazıp soru sayısı kadar sağ tarafa ve sonra öğrenci sayısına göre aşağı doğru çekerek tüm hücrelere kopyalayalım
    Kod:
      Kodları görebilmek için ÜYE omalısınız !
    Böylece doğru cevapları ve öğrencilerin verdiği cevapları sayfamıza otomatik olarak çekmiş olduk.

    [​IMG]

    Artık öğrencilerin hangi soruya doğru cevap verip vermediklerini analiz etmemiz gerekiyor. Bunun için sonuçlar sayfasına aşağıdaki resimde olduğu gibi bir tablo hazırlayalım. Cevaplar sayfasında olduğu gibi bu sayfaya da aynı yöntemle doğru cevapları alalım. Aslında buna gerek yok ama daha anlaşılır olması için ben uygulamada bunu yaptım.

    E3 hücresine aşağıdaki formülü girip öğrencinin verdiği cevabın doğru olup olmadığını kontrol etmemiz gerekiyor.
    Kod:
      Kodları görebilmek için ÜYE omalısınız !
    Bu förmülü de soru ve öğrenci sayısına göre sağa ve aşağı doğru sürükleyerek ilgili hücrelere kopyaladık. Aşağıdaki resimde görüldüğü gibi verilen cevaplara göre hücrelere Doğru için "D", yanlış cevap için "Y" yazdırdık. Boş bırakılan soru ise bizim hücremizde de boş görünüyor.

    [​IMG]

    Extra işlemler için kullanılan formüller:

    Yukarıdaki yabloda yanlış soruların renklenmesi için ilgili alanı seçip Koşullu Biçimlendirme bölümünden Hücre Değeri alanını Eşit seçip ilgili alana ="Y" yazabilirsiniz. Sonra da Stil butonu ile renklendirmek mümkün. Bunu doğru cevaplar için de ek olarak yapmanız mümkün.

    Soru sayısını öğrenmek için (İlk sayfanıza girdiğiniz cevaplara göre): =UZUNLUK('Liste-Cevap'!E1)
    Doğru cevap sayısını almak için kullanacağınız formül: =EĞERSAY(E3:AH3;"D")
    Yanlış cevap sayısını almak için kullanacağınız formül: =EĞERSAY(E3:AH3;"Y")
    Boş soru sayısını almak için: =AK1-(AI3+AJ3)
    Not Hesaplamak için: =(100/$AK$1)*AI3

    Karışık görünmesine rağmen son derece kolay bir uygulama. Yaptığınız sınavların analizi için kullanabilirsiniz.
     

    Ekli Dosyalar:

  2. YuNuSs

    YuNuSs Üyecik

    Katılım:
    2 Kasım 2012
    Mesajlar:
    3
    Beğenileri:
    0
    Ödül Puanları:
    20
    Banka:
    0 ÇTL
    eLine koLuna akLına sağLık kardesim. prog biraz düzenLedim ve vize ödevim oLdu,sayende dersi geçeceğim tskrler .. ama hala progda anLamadığım tek bir nokta war doğru oLduğunda beyaz kutucuk içinde D yazıyor , yanlış oLduğunda Y yazıyor tmm da nasıL kutucuğu kırmızı yapıyor ?
     
  3. YoRuMSuZ
    Avare

    YoRuMSuZ Biz işimize bakalım!

    Katılım:
    7 Haziran 2006
    Mesajlar:
    24.416
    Beğenileri:
    7.327
    Ödül Puanları:
    11.330
    Cinsiyet:
    Bay
    Banka:
    8.722 ÇTL
    En kolay bölümde takılmışsınız. Koşullu biçimlendirme ile ilgili konularımızda bunun fazlaca örnekleri mevcut. Koşula göre excelde istediğiniz hücreyi istediğiniz şekilde renklendirebilir veya şekillendirebilirsiniz.
     
  4. bayanasya

    bayanasya Üyecik

    Katılım:
    16 Aralık 2012
    Mesajlar:
    1
    Beğenileri:
    0
    Ödül Puanları:
    20
    Banka:
    0 ÇTL
    =PARÇAAL('Liste-Cevap'!$E1;1;1) Yazıyorum ama sağa doğru çektiğimde rakamlar hep aynı kalıyor. Hep aynı değer geliyor. Nedenini anlayamadım. Formülde nerede hatam var?
     
  5. YoRuMSuZ
    Avare

    YoRuMSuZ Biz işimize bakalım!

    Katılım:
    7 Haziran 2006
    Mesajlar:
    24.416
    Beğenileri:
    7.327
    Ödül Puanları:
    11.330
    Cinsiyet:
    Bay
    Banka:
    8.722 ÇTL
    Örneği indirip deneyin, formülde hata olsa örnek dosyada sorun olur değil mi?
     
  6. bayphilo

    bayphilo Üyecik

    Katılım:
    Salı
    Mesajlar:
    1
    Beğenileri:
    0
    Ödül Puanları:
    120
    Cinsiyet:
    Bay
    Banka:
    15 ÇTL
    Arkadaşlar buradaki konu çok işime yaradı. Çok teşekkür ediyorum. Kitapçık türünü seçerek doğru yanlışı nasıl saydıracağım. Çok uğraştım yapamadım. Yardım ederseniz sevinirim.
     
  7. YoRuMSuZ
    Avare

    YoRuMSuZ Biz işimize bakalım!

    Katılım:
    7 Haziran 2006
    Mesajlar:
    24.416
    Beğenileri:
    7.327
    Ödül Puanları:
    11.330
    Cinsiyet:
    Bay
    Banka:
    8.722 ÇTL
    Çok eskiden eklediğim bir excel dosyası. "Eğer" fonksiyonu ile bu soruna çözüm bulunabilir.
     

Sayfayı Paylaş