Excel koşullu alt toplamlar

Katılım
25 Hzr 2008
Mesajlar
1
Beğeniler
0
#1
Merhaba sayın dostlar,

Kullanmakta olduğum bir takip dosyasında USD ve USD harici bakiyelerin toplamlarını listelemem gerekiyor. Uzun bir girdi listem var (160 küsür satır). Liste yapısı aşağıdaki örnekte gibi. Satırları değiştirmemem gerekiyor. (döviz cinslerine göre sıralama yapıp toplam alamıyorum)

AA BB CC
EGP 4.000.000,00 $ 735.000,00
EUR 19.912,00 $ 30.973,12
EUR 28.400,00 $ 44.176,20
USD 17.391.304,00 $ 17.391.304,00
USD 30.600,00 $ 30.600,00

AA (Döviz cinsi); BB (işlem meblağı); CC (USD karşılık -zaten USD ise BB aynen taşımıyor, farklı ise baz pariteden karşılığı manuel olarak giriliyor)

Toplama işleminin; asli USD olanlar ayrı toplanacak (BB değerleri), USd harici veriler ise USD karşılıklarından (CC değerleri) toplanacak.

SONUÇ TOPLAM Bakiye (USD olanlar) -a
TOPLAM Bakiye (USD harici) -b

YEKÜN USD BAKİYE (a+b)

Yardımlarınızı beklemekteyim...
 

YoRuMSuZ

Biz işimize bakalım...
Katılım
7 Hzr 2006
Mesajlar
37,477
Beğeniler
9,012
Takım
GALATASARAY
#2
Soru biraz karışık sorulmuş. Anladığım kadarı ile;

AA sütununda döviz cinsi adı;
BB sütununda döviz cinsinde tutar yazmakta.

Sizin istediğiniz eğer sütundaki sadece USD olan satırları toplamaksa ETOPLA fonksiyonu ile yapabilirsiniz.

Sütunlarda 10'ar satır olduğunu varsayarsak formül;

Kod:
=ETOPLA(AA1:AA10;"*USD*";BB1:BB10)
Formüle göre AA sütununda USD yazanların karşılarındaki rakamları topladık.

Eğer ingilizce excel kullanıyorsanız ETOPLA karışılığı SUMIF
 
Top