excelde "eğer" fonsiyonunun kullanımı

Katılım
16 Eyl 2009
Mesajlar
6
Beğeniler
0
#1
iyi günler
a1 hücresine bir değer girdiğimizde d1 hücresi 2 değerini
a2 hücresine bir değer girdiğimizde d1 hücresi 3 değerini
a3 hücresine bir değer girdiğimizde d1 hücresi 4 değerini almasını istiyorum formülünü yazabilir misiniz?
 
Katılım
16 Eyl 2009
Mesajlar
6
Beğeniler
0
#2
a1 hücresine herhangi bir yazı karakteri girdiğimizde d1 hücresi 1 değerini
a2 hücresine herhangi bir yazı karakteri girdiğimizde d1 hücresi 2 değerini
a3 hücresine herhangi bir yazı karakteri girdiğimizde d1 hücresi 3 değerini almasını bu hücrelerin boş olması halinde d1 hücresinin boş olarak görünmesi için bir formül gerekiyor yardımcı olursanız sevinirim.
 

YoRuMSuZ

Biz işimize bakalım...
Katılım
7 Hzr 2006
Mesajlar
37,468
Beğeniler
8,989
Takım
GALATASARAY
#3
Neden farklı hücrelere girdiğiniz hücreleri bir alanda sorguluyosunuz ki anlayamadım.

Şu şekilde boş olup olmadığı kontrol edilebilir.

B1 hücresine şu formülüyazın.

Kod:
=EĞER(EBOŞSA(A1);"";"dolu")
Bu durumda A1 hücresi boşsa B1 boş görünecek. Veri girerseniz dolu yazacktır.

Ama istediğiniz sanırım dolusatır sayısını bulmak. Eğer böyleyse şu förmül işinizi görür.

A1 - A10 hücre aralığındaki dolu satırların sayısını alıyoruz. Formülü B1 hücresine girin.

Kod:
=EĞERSAY(A1:A10;"*")
Böylece A1 - A10 arlığındaki dolu satırları saydırdık. A sütununa veri girdikçe B1 hücresindeki sayı otomatik olarak değişecektir.

Not: Rakamsal alanları saymaz.
 
Katılım
16 Eyl 2009
Mesajlar
6
Beğeniler
0
#4
cevap için teşekkürler ancak sorumu şu şekilde düzelteyim.
a1 hücresine herhangi bir metin girdiğimde b1 hücresi "ahmet"
a2 hücresine herhangi bir metin girdiğimde b1 hücresi "mehmet"
a3 hücresine herhangi bir metin girdiğimde b1 hücresi "veli" biçiminde yazabilir mi diye sorayım (a1,a2,a3 hücreleri boş olduğunda b1 hücresi boş, ancak bu üç hücreden herhangi birine bir metin girdiğimde metin girdiğim hücrenin karşılığı b1 hücresinde yazsın) böyle bir formül olabilir mi? eğer bir hatamız olmuşsa affola. ilginize teşekkürler
 

YoRuMSuZ

Biz işimize bakalım...
Katılım
7 Hzr 2006
Mesajlar
37,468
Beğeniler
8,989
Takım
GALATASARAY
#5
Muhtemelen istediğiniz bir şekilde yapılır ama şöyle düşünelim. A1 hücresindeki veriye göre B1 hücesine referans verdik. Şimdi de A2 hücresine göre B1 e yine referans istiyosunuz. Sonuçta bir çakışma olacak. Hadi dolu hücreleri sayalım vs ama bu referansı çakışma üzerine kurarsanız emin oldun sağlıklı çalışmayacak excel dosyanız.

Konuya hakim arkadaşlar varsa cevap verecektir. Beni aşar artı mantığa aykırı istediğiniz şey.
 
Katılım
14 Şbt 2011
Mesajlar
1
Beğeniler
0
#6
Anladığım kadarıyla sorunuza cevap olacak formülü yazdım. Umarım işinize yarar. B1 hücresine yazılacak formül:
=EĞER(A1="";EĞER(A2="";EĞER(A3="";"";"VELİ");"MEHMET");"AHMET")
Bu formülde öncelikle boş hücre sorgulanıyor ve boşsa diğer hücre sorgulanıyor (A1 A2 A3), boş olmayan hücrenin karşılığı olan metin yazılıyor. Ancak bu formül aynı anda birden fazla hücrenin dolu olmayacağı varsayımıyla çalışan formüldür.
 

Benzer konular

Top