excelde farklı girdilerin sayısını almak

husmen

Üyecik
Katılım
8 Eyl 2009
Mesajlar
3
Beğeniler
0
Yaş
33
#1
paylaşımlarınız için çok teşekkür ederim. baya faydası oldu.
bi konuda yardıma ihtiyacım var.300 400 girdilik bir listede çoğunluğu farklı ama arada aynı isimle girdilerin olduğu bi tablom war

ali 100 kalem
veli 50 kalem
ali 40 kalem
hüseyin 20 kalem
ahmet 30 kalem
mehmet 500 kalem
veli 10 kalem
ali 100 kalem

gibi. tablodaki kalem alan farklı kişi sayısını verebilecek bi formül arıyorum. lisetedeki ali lerin hepsini deil de sadece birini toplama dahil edebilicek? mesela bu tabloda bana 8 yerine 5 sonucunu verebilecek


şimdiden teşekkür ederim
 
Katılım
7 Hzr 2006
Mesajlar
36,717
Beğeniler
8,973
Takım
GALATASARAY
#2
Bu verilerin A1-A8 ve B2-B8 hücrelerine girildiğini varsayıyorum.

Eğer bu tabloda sadece ali'lerin sayısını bulmak istiyorsanız formül;
=EĞERSAY(A1:A8;"=ali")
Bu size sütundaki ali'lerin kaç kez geçtiğinin sayısını verecektir.

Eğer ali'ye ait rakamsal verilerin toplamını istiyorsanız. Formül şu şekilde olmalı.
=ETOPLA(A1:B8;"=ali";B1:B8)
 

husmen

Üyecik
Katılım
8 Eyl 2009
Mesajlar
3
Beğeniler
0
Yaş
33
#3
hayır bana kalem sayılarının toplamlarını sormuyorum. sadece kaç farklı kişi benden alışveriş yapmıştır onu saydırmak istiyorum. listedeki alileri sadece 1, velileri 1 sayıcak bi formül war mıdır ?
 
Katılım
7 Hzr 2006
Mesajlar
36,717
Beğeniler
8,973
Takım
GALATASARAY
#4
Kullanmanız gereken formül;
=EĞERSAY($A$1:$A$8;"ali")
Bu formül size A1-A8 aralığındaki ali'lerin sayısını verecektir.

veya şu şekilde kullanabilirsiniz. Yukarıdaki ile aynı işleve sahiptir.
=EĞERSAY(A1:A8;"=ali")
Sütunda geçen diğer isimleri de bulmak için aynı yöntemi denemekle birlikte hem üstteki formülü her bir isim için kullanabilir hem de şöyle bir yol izleyip olayı otomatikleştirebilirsiniz.

Sütunda geçen farklı isimleri yatay düzlemde birer kez yazarız. Örneğin C3 hücresine ali yazdık herhangi bir hücreye şu formüllü yazıyoruz.
=EĞERSAY($A$1:$A$8;C$1)
 
Katılım
8 Eyl 2009
Mesajlar
3
Beğeniler
0
Yaş
33
#5
zaten herbi farklı isimleri bulmaya çalışıyorum ki yaklaşık 600 tane farklı isim var.ben bu sayının tam kaç olduğunu bilmek istiyorum ve listeye hergün yeni veriler giriyorum. ekledikce ne kadar farklılaştığını görmek istiyorum. ve 2. verdiğin formülde yatay düzleme yazarız demişsin ama anlamadım. sanırım farklısay veya farklıbul diye bi formül yoktu.
 
Katılım
7 Hzr 2006
Mesajlar
36,717
Beğeniler
8,973
Takım
GALATASARAY
#6
Şu an grup isimlerini alabilecek bir formül hatırlayamıyorum veya yok olabilir. Yatay düzlemden kastım yatay sırada idi.

Aklıma gelen bir yöntem. Eğer kaç farklı ismin geçtiğini bulmaksa Özet Tablo işlemi işimize yarayabilir. İsimlerin geçtiği hücreleri kapsayan özet tablo oluşturun. Özet tabloda aynı isimler bir kez tekrarlanacaktır.

Sonra özet tablosunun veri aralığını saydırıp bulun. Örn: =SATIRSAY(F10:F150) gibi.

Bu yöntemle kaç farklı kişiye ait veri olduğunu bulabilirsiniz. Bu kez de yanlış anladıysam sorunuzu hakikaten boşuna kürek çekiyorum demektir. Net şekilde soruyu almalıyım.

Bir hatırlatma. Bu tür uygulamalarda örnek bir excel dosyasını herhangi biryere upload edin. Tablo yapısını tekrar oluşturmak zorunda kalıyorum zaman zaman.
 

Benzer konular

Top