• Merhaba Ziyaretçi
    Yarışma konusu belirlemek için açılan ankete BURADAN ulaşabilirsiniz. Sizi de ankete oy vermeye davet ediyoruz...
Kaynak ikonu

Excel ile Sınav Analizi yapalım -

İndirmek için giriş yapınız
Excel içerisinde işlerimizi kolaylaştıran bir çok işlev ve fonksiyonu barındırıyor. Biz şimdi basit düzeyde sınav analiz programı yapalım. Böylece bazı formüllerin nasıl kullanıldığını da öğrenmiş olalım.

İsterseniz uygulama dosyasını eklentiden indirebilirsiniz.

Konu: Excel ile sınav analizi
Zorluk: Basit / Orta

Bunun için aşağıdaki resimde görüldüğü gibi 3 sayfadan oluşan bir excel dosyası kullanıyoruz. Aynı isimleri kullanırsanız formülleri kullanmada zorluk çekmezsiniz.

Sayfa isimleri: Liste-Cevap, Cevaplar, Sonuclar

Liste-Cevap sayfası bizim veri gireceğimiz sayfadır. Diğer sayfalara elle veri girmiyoruz, çünkü diğer sayfalar sonuçları bu sayfadan formüllerle alacak. Resimdeki şekilde tablomuzu hazırladık ve doğru üstteki bölüme doğru cevapları, öğrencilerin bölümüne ise öğrencilerin sınavda verdikleri cevapları giriyoruz.

Buradaki sınav sonuçları bir hücreye girilip (kolaylık olması açısından) daha sonra PARÇAAL fonksiyonu ile ayıracağız.

Öğrencinin boş bıraktığı soru için biz de bir boşluk bırakıyoruz. 1 numaralı öğrencinin cevaplarında görüldüğü gibi.

excel_sinav_analiz1.png


Artık sonuçları almaya başlıyoruz. Aşağıdaki resimde görüldüğü gibi bir tablo hazırlayalım ve verileri Liste-Cevap sayfasından çekmeye başlayalım. Girdiğimiz formülleri diğer hücrelere uygulamak için sürükleyip bırakmak yeterli.

Burada önemli olan Doğru cevapları ve öğrencilerin verdikleri cevapları PARÇAAL fonksiyonu ile almak ve

E1 hücresine doğru cevapları parçalayarak almak için şu formülü yazalım ve soru sayısına göre sağa doğru sürükleyelim.
Kod:
=PARÇAAL('Liste-Cevap'!$E1;1;1)
E3 hücresine de öğrencilerin verdiği cevapları almak için alttaki formülü yazıp soru sayısı kadar sağ tarafa ve sonra öğrenci sayısına göre aşağı doğru çekerek tüm hücrelere kopyalayalım
Kod:
=PARÇAAL('Liste-Cevap'!$E3;1;1)
Böylece doğru cevapları ve öğrencilerin verdiği cevapları sayfamıza otomatik olarak çekmiş olduk.

excel_sinav_analiz2.png


Artık öğrencilerin hangi soruya doğru cevap verip vermediklerini analiz etmemiz gerekiyor. Bunun için sonuçlar sayfasına aşağıdaki resimde olduğu gibi bir tablo hazırlayalım. Cevaplar sayfasında olduğu gibi bu sayfaya da aynı yöntemle doğru cevapları alalım. Aslında buna gerek yok ama daha anlaşılır olması için ben uygulamada bunu yaptım.

E3 hücresine aşağıdaki formülü girip öğrencinin verdiği cevabın doğru olup olmadığını kontrol etmemiz gerekiyor.
Kod:
=EĞER(Cevaplar!E3="";"";(EĞER(Cevaplar!E3=Cevaplar!E$1;"D";EĞER(Cevaplar!E3="?";"Y";EĞER(Cevaplar!E3=" ";"";"Y")))))
Bu förmülü de soru ve öğrenci sayısına göre sağa ve aşağı doğru sürükleyerek ilgili hücrelere kopyaladık. Aşağıdaki resimde görüldüğü gibi verilen cevaplara göre hücrelere Doğru için "D", yanlış cevap için "Y" yazdırdık. Boş bırakılan soru ise bizim hücremizde de boş görünüyor.

excel_sinav_analiz3.png


Extra işlemler için kullanılan formüller:

Yukarıdaki yabloda yanlış soruların renklenmesi için ilgili alanı seçip Koşullu Biçimlendirme bölümünden Hücre Değeri alanını Eşit seçip ilgili alana ="Y" yazabilirsiniz. Sonra da Stil butonu ile renklendirmek mümkün. Bunu doğru cevaplar için de ek olarak yapmanız mümkün.

Soru sayısını öğrenmek için (İlk sayfanıza girdiğiniz cevaplara göre): =UZUNLUK('Liste-Cevap'!E1)
Doğru cevap sayısını almak için kullanacağınız formül: =EĞERSAY(E3:AH3;"D")
Yanlış cevap sayısını almak için kullanacağınız formül: =EĞERSAY(E3:AH3;"Y")
Boş soru sayısını almak için: =AK1-(AI3+AJ3)
Not Hesaplamak için: =(100/$AK$1)*AI3

Karışık görünmesine rağmen son derece kolay bir uygulama. Yaptığınız sınavların analizi için kullanabilirsiniz.

excel_sinav_analiz1.png excel_sinav_analiz2.png excel_sinav_analiz3.png
Gönderen
YoRuMSuZ
İndirilme
12
İlk yayınlama
Son güncelleme
Değerlendirme
0.00 star(s) 0 ratings

YoRuMSuZ ait diğer kaynakar

Top